FBS Support Phone System
Incident Report for FBS
Resolved
This incident has been resolved.
Posted Jun 05, 2023 - 16:15 CDT
Monitoring
A fix to our phone system has been deployed that is allowing support calls to reach us again.
Posted Jun 05, 2023 - 14:02 CDT
Investigating
There is a confirmed unplanned issue with our phone system that is preventing our support team from answering your support call. While we work with our phone carrier to resolve the issue, our support is is available via email at support@flexmls.com. We apologize for this inconvenience.
Posted Jun 05, 2023 - 12:50 CDT
This incident affected: Flexmls Support.